09:00:02 <szlin> #startmeeting CIP IRC weekly meeting
09:00:02 <brlogger> Meeting started Thu Aug  1 09:00:02 2019 UTC and is due to finish in 60 minutes.  The chair is szlin. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:02 <brlogger> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:02 <brlogger> The meeting name has been set to 'cip_irc_weekly_meeting'
09:00:16 <szlin> #topic rollcall
09:00:22 <szlin> please say hi if you're around
09:00:26 <pave1> hi
09:00:27 <kazu> hi
09:00:28 <vidda> hi
09:00:37 <patersonc> hi
09:00:38 <bwh> hi
09:00:55 <szlin> #topic AI review
09:01:04 <szlin> 1. Provide the script for CIP kernel config collection - bwh
09:01:05 <fujita[m]> hi
09:01:06 <szlin> #link https://lists.cip-project.org/pipermail/cip-dev/2019-June/002506.html
09:01:14 <bwh> I think this is done
09:01:37 <szlin> bwh: thank you
09:01:48 <szlin> 2. Work out a solution for LAVA master backups - patersonc
09:01:57 <yamamodo> hi
09:02:00 <patersonc> Not done. Sorry!
09:02:16 <szlin> patersonc: no worry
09:02:30 <szlin> 3. Provide the cases to cip-testing to build up the test environment - Iwamatsu-san
09:02:53 <szlin> Iwamatsu-san cannot attend today's meeting, I will ask him after the meeting
09:03:11 <szlin> 4. Ask cip-dev which configurations need testing - patersonc
09:03:22 <patersonc> I asked, no response yet though :(
09:03:57 <szlin> patersonc: it's in my work queue, sorry for late
09:04:06 <patersonc> np
09:04:30 <pave1> If you are collecting configurations, would it be possible to add the results to the README file?
09:04:47 <pave1> Name of target we normally use, name of target in the LAVA lab, config...
09:05:01 <patersonc> pave1: That's my plan
09:05:13 <pave1> patersonc: Thanks!
09:05:17 <patersonc> pave1: I just need to get the info from those who know :)
09:05:30 <pave1> :-)
09:05:50 <szlin> 5. Confirm we can enable high-res timers for every board - pavel
09:06:32 <pave1> I guess I need to hear from people who konw about the configs...
09:06:43 <pave1> ...or we can just enable it and see what happens. I don't expect problems there.
09:07:12 <patersonc> The RZ/G boards should be okay
09:08:00 <szlin> How about sending the email to cip-members mailing list
09:08:57 <pave1> It was outlined in "plan for rt testing" email, but I did not get much response there.
09:09:14 <pave1> I can try again I guess.
09:09:22 <szlin> pave1: thanks
09:09:41 <szlin> 7. Test LTS (pre)releases directly - patersonc
09:10:05 <patersonc> Nothing done on that front yet.
09:10:42 <szlin> 8. Discuss the primary repository in CIP kernel development (kernel.org or gitlab) - kernel team
09:11:07 <szlin> I plan to send the email to discuss this item before this week
09:11:21 <szlin> #topic Kernel maintenance updates
09:11:52 <szlin> pave1: do you have any updates on kernel maintenance?
09:11:57 <pave1> There was ton of patches in stable. Reviewed 4.19.61, 4.19.62, 4.19.63.
09:12:02 <pave1> Hopefully it should now calm down now.
09:12:29 <szlin> pave1: thank you.
09:12:53 <szlin> bwh: do you have any updates with this topic?
09:13:13 <bwh> no I don't
09:13:30 <szlin> any other points?
09:13:45 <szlin> 3
09:13:46 <szlin> 2
09:13:46 <szlin> 1
09:13:55 <szlin> #topic Kernel testing
09:14:17 <patersonc> Changes to the directory structure of cip-kernel-config broke my CI setup :(
09:14:25 <szlin> oops
09:14:34 <patersonc> So I've submitted some new versions of gitlab-ci.yml to the ML
09:14:45 <patersonc> It would be good if they could be reviewed/applied asap
09:14:48 <pave1> Yep, thanks, I'll take a look and merge them.
09:14:55 <patersonc> Thanks
09:15:16 <patersonc> I'm still waiting on official approval to move the linux-cip-ci project to the cip-project namespace
09:15:24 <szlin> #action Review and merge "gitlab-ci.yml" - pavel
09:15:36 <patersonc> When I get approval, I'll submit more updates for gitlab-ci.yml - sorry for the churn.
09:15:57 <patersonc> And when people tell me what configs they want to build, there will also be more updates to the CI files...
09:16:55 <patersonc> Powerpc support is done, although not merged yet. I'm just waiting for confirmation from Toshiba that they are happy to ignore the build warnings triggered by gcc v8.1.0
09:17:10 <patersonc> Ideally we should fix these warnings though...
09:17:32 <pave1> patersonc: Well, they are known to be caused by gcc bug...
09:17:49 <patersonc> Ah, so not a bug in the code then?
09:17:58 <pave1> ...and testing any changes there will not be trivial.
09:18:13 <patersonc> Here's a question - did CIP ever decide on a GCC version we're meant to be using/supporting?
09:18:27 <pave1> I posted pointer to gcc bugzilla IIRC... so no, this not kernel problem.
09:18:40 <pave1> And yes, it could be solved by using different gcc version.
09:18:43 <szlin> kazu: ^ do you have any idea ?
09:18:50 <pave1> But I believe just disabling the warning is also fine.
09:19:08 <fujita[m]> GCC version should be follow to CIP core
09:19:22 <kazu> We discussed about this topics,
09:20:20 <szlin> kazu: let's have some discussion after the meeting
09:20:23 <szlin> any other points?
09:20:25 <szlin> 3
09:20:26 <szlin> 2
09:20:27 <szlin> 1
09:20:39 <szlin> #topic CIP Core
09:20:53 <kazu> then planning to drop the requirements about this issue
09:21:11 <kazu> we would like to share the information later...
09:21:38 <kazu> regarding CIP-Core, thank you very much for many discussion in OSSJ!
09:21:50 <kazu> Package decision process (PDP):
09:21:56 <kazu> [WIP] A script to generate run-time package lists are now being implemented
09:22:04 <kazu> We would provide a draft in the next TSC meeting
09:22:13 <kazu> CIP security depends on this work, so working with high priority
09:22:28 <kazu> FYI: DebConf19 info: #link https://lists.cip-project.org/mailman/private/cip-members/2019-July/002034.html
09:22:52 <kazu> regarding Reproducible Builds,
09:23:01 <kazu> Short summary: The most (around 90%) packages CIP requested are reproducible, under the condition the build path is not variant
09:23:29 <kazu> Now we (TOSHIBA) are planinng to
09:23:33 <kazu> 1. try steps to reproduce packages with srebuild (in our local)
09:23:51 <kazu> 2. look at remaining Reproducible Builds issues in buster/bullseye then consider creating patches to fix them
09:24:11 <kazu> If you are interested in this topic, please let me know
09:24:18 <kazu> Debian LTS/ELTS:
09:24:37 <kazu> I've summarized the latest state, especially about ELTS (current target: wheezy). Please check the email to cip-members about this
09:24:50 <kazu> [WIP] TOSHIBA is now confirming the requirements of ELTS for jessie.
09:25:04 <kazu> We will send the summary to Renesas members then share our direction in TSC.
09:25:25 <kazu> That's all from me, If any other AIs I'm missing, please let me know
09:25:42 <szlin> kazu: thank you for your update.
09:25:48 <szlin> any question?
09:26:20 <szlin> 3
09:26:21 <szlin> 2
09:26:22 <szlin> 1
09:26:29 <szlin> #topic Software update
09:26:37 <szlin> kazu: is Daniel around?
09:26:58 <kazu> No
09:27:15 <kazu> sorry, I cannot tell the updates about this topic today...
09:27:25 <szlin> kazu: thanks, I will jump to next topic
09:27:34 <szlin> any other points?
09:27:38 <szlin> 3
09:27:39 <szlin> 2
09:27:39 <szlin> 1
09:27:41 <szlin> #topic AOB
09:27:47 <szlin> any other business?
09:28:07 <szlin> 3
09:28:08 <szlin> 2
09:28:08 <szlin> 1
09:28:16 <szlin> #endmeeting