09:00:23 <gavinlai> #startmeeting CIP IRC weekly meeting
09:00:23 <brlogger> Meeting started Thu Jun 13 09:00:23 2019 UTC and is due to finish in 60 minutes.  The chair is gavinlai. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:23 <brlogger> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:23 <brlogger> The meeting name has been set to 'cip_irc_weekly_meeting'
09:00:29 <patersonc> Mornin
09:00:36 <gavinlai> #topic rollcall
09:00:42 <sangorrin> hi
09:00:42 <gavinlai> please say hi if you're here
09:00:45 <pave1> hi
09:00:46 <vidda> hi
09:00:51 <iwamatsu> hi
09:00:52 <mungaip[m]> hi
09:00:55 <fujita[m]> hi
09:00:56 <patersonc> hi
09:01:29 <gavinlai> #topic AI review
09:01:42 <gavinlai> 1. send investigating email for kernel-testing lab to cip-dev - patersonc
09:01:55 <gavinlai> #link  https://lists.cip-project.org/pipermail/cip-dev/2019-June/002461.html
09:02:13 <patersonc> Sorry, no updates from me. I'm waiting for some internal discussions first...
09:02:23 <gavinlai> I will keep this action item :)
09:02:33 <gavinlai> #action send investigating email for kernel-testing lab to cip-dev - patersonc
09:02:48 <gavinlai> 2. Provide the script for CIP kernel config collection - bwh
09:03:17 <gavinlai> bwh: (wave
09:03:19 <pave1> bwh did not say hi in the rollcall.
09:03:38 <gavinlai> I will keep this action item
09:03:45 <gavinlai> #action Provide the script for CIP kernel config collection - bwh
09:03:54 <gavinlai> 3. Provide the plan about next cip-rt kernel release - szlin
09:04:14 <gavinlai> szlin have already reported to TSC to look for a maintainer
09:04:27 <gavinlai> szlin will list some questions to ask Daniel wagner
09:04:48 <gavinlai> #action list some questions to ask Daniel wagner - szlin
09:05:03 <gavinlai> #topic Kernel maintenance updates
09:05:40 <pave1> So... I reviewed 4.19.49 and 4.19.50.
09:06:01 <pave1> I'm starting to create a list of directories that need not be reviewed. It will go to the lists eventually.
09:06:22 <pave1> I have some questions, such as "is anyone using btrfs -- do we need to review it"?
09:06:48 <iwamatsu> I reviewed 4.4.160  and stable-rc in stable@kernel.org. I'm sending some review and patches.
09:07:21 <gavinlai> cool, thanks
09:07:57 <iwamatsu> pave1: we do not use btrfs, and not target.
09:08:08 <gavinlai> how to finalize the list?
09:08:19 <iwamatsu> I think we can ignore commit of btrfs .
09:08:46 <iwamatsu> we manage review list in https://gitlab.com/cip-project/cip-kernel/lts-commit-list/
09:09:16 <pave1> I think we can ignore btrfs, too.
09:09:46 <pave1> Do we only care about configurations we have collected, or do we also support "hmm, someone is going to enable this config option"?
09:11:00 <gavinlai> by request I guess?
09:11:01 <fujita[m]> I think it needs similar steps as CIP core
09:11:27 <iwamatsu> I think we need to list the features we can ignore, and we ask about list in cip-dev or other.
09:11:32 <fujita[m]> propose -> vote -> decide
09:11:51 <gavinlai> agree
09:11:52 <iwamatsu> fujita[m]: +1
09:12:15 <pave1> iwamatsu: Agreed. I'll start collecting paths we can ignore.
09:12:44 <gavinlai> pave1: thanks
09:12:51 <iwamatsu> pave1: ok, thanks
09:12:53 <pave1> There's some stuff we definitely can ignore (s390). I'll ask about stuff that is not completely clear. (btrfs? isofs?)
09:13:36 <gavinlai> any other update?
09:13:48 <gavinlai> #topic Kernel testing
09:13:52 <iwamatsu> Also, I think that list will probably be a feature supported by the CIP kernel.
09:14:51 <patersonc> Hello
09:15:00 <patersonc> The LAVA master has been updated to the latest version in CIP's lava-docker repository.
09:15:11 <patersonc> There were some issues and a small amount of recent test data was lost (sorry iwamatsu).
09:15:12 <patersonc> We've now added some scripts to make the process full-proof for next time (famous last words).
09:15:17 <patersonc> I've requested direct access to the server so we can do this ourselves in future, which should make it easier.
09:15:20 <patersonc> When we get access we'll probably start trying to stick to a published update schedule so that users know in advance of any downtime.
09:15:27 <patersonc> Setting up lab-cip-mentor is almost complete. Just waiting on the LAVA master's key to be shared with Mentor.
09:15:38 <patersonc> I've managed to find time this week to work on the GitLab CI Kernel builds. I'll push everything to cip-playground when ready for review.
09:15:39 <patersonc> Could someone make me a moderator/admin on our linux-cip GitLab? I'll need access to setup the GitLab CI.
09:15:54 <iwamatsu> patersonc: No problem.
09:16:52 <iwamatsu> SZlin is one of owner.
09:16:57 <patersonc> Does anyone have owner access for linux-cip?
09:17:22 <patersonc> Okay. I'll ask szlin then. Thanks
09:17:33 <patersonc> For OSS-J, I'm thinking about holding a quick meeting on the 15th - the Monday before the event. This will be at the same location as the CIP Core meetings.
09:17:54 <patersonc> Is anyone interested in a CIP testing specific meeting?
09:18:02 <sangorrin> me
09:18:16 <iwamatsu> hm, toscalix is ower yet. I think we remove him from owner .
09:18:17 <patersonc> I guessed you ;)
09:18:55 <patersonc> iwamatsu: Probably a good idea. There are probably lots of things Agustin is still owner of ;)
09:18:56 <iwamatsu> I am interesting it.
09:19:17 <patersonc> laurence-, do you want to take over access from Agustin?
09:19:59 <patersonc> Thanks iwamatsu
09:20:03 <patersonc> I'll start planning.
09:20:14 <patersonc> That's it from me, unless there are any questions?
09:20:19 <gavinlai> patersonc: thanks
09:20:20 <iwamatsu> patersonc: Thanks.
09:20:43 <gavinlai> #topic CIP Core
09:21:23 <sangorrin> Deby's gitlab-ci.yml is now working
09:21:41 <sangorrin> About Isar, I sent a merge request for iwg20m
09:21:48 <sangorrin> https://gitlab.com/cip-project/cip-core/isar-cip-core/merge_requests
09:22:01 <sangorrin> that's all
09:22:12 <pave1> I understand there's cip core meeting on zoom
09:22:24 <pave1> at june 18.
09:22:27 <sangorrin> Hayashi-san sent a doodle I think
09:22:35 <pave1> Yep. I wanted to ask:
09:22:48 <pave1> Does it make sense for me to join it if time permits?
09:23:03 <sangorrin> probably not much
09:23:14 <pave1> Ok.
09:23:52 <gavinlai> :)
09:23:55 <gavinlai> next topic?
09:24:03 <gavinlai> #topic Software update
09:24:23 <sangorrin> We have a new branch in isar-cip-core (storm/swupdate)
09:24:37 <sangorrin> there we have recipes for u-boot, swupdate, and some scripts
09:24:46 <sangorrin> we will build up on that repository
09:25:21 <gavinlai> sangorrin: thanks
09:25:26 <gavinlai> any comments?
09:26:02 <gavinlai> #topic AOB
09:26:18 <pave1> I wanted to ask about realtime.
09:26:40 <pave1> I took a look at patches; they are scary (8000 lines), but not _that_ scary.
09:27:03 <pave1> Is someone using realtime capabilities?
09:27:08 <pave1> If so, on what hardware?
09:27:09 <sangorrin> yes
09:27:24 <sangorrin> on x86_64 and ARM32
09:27:48 <pave1> Are there special configs for x86-64 (like this board, with SMM disabled?)
09:28:06 <sangorrin> in isar-cip-core you can see rt configs
09:28:13 <pave1> Ok.
09:28:35 <pave1> Are you running tests of the realtime latencies?
09:28:37 <sangorrin> https://gitlab.com/cip-project/cip-core/isar-cip-core/blob/next/recipes-kernel/linux/files/preempt-rt.cfg
09:28:47 <sangorrin> yes
09:28:52 <sangorrin> rt-tests
09:29:15 <sangorrin> Daniel Wagner also created new tests and a test environment using kexec to get crash dumps
09:29:34 <pave1> Aha, good. So if someone prepares kernel for you, you can make reasonably sure that it works ok?
09:29:57 <pave1> Because in my eyes preparing the kernel is not that hard, testing is :-).
09:30:10 <sangorrin> well, with RT you never know. Sometimes bugs only manifest after 30 hours
09:30:22 <pave1> Yes, that's the scary thing about RT.
09:30:38 <pave1> That and fact that RT systems are often used for critical stuff.
09:30:47 <patersonc> Daniel did start working on a RT test suite
09:30:55 <patersonc> I'm not sure where he got to though
09:31:22 <sangorrin> everything is explained on his github account
09:31:55 <sangorrin> https://github.com/igaw
09:31:58 <pave1> Ok, thanks for the information.
09:32:21 <sangorrin> for kernel maintainers: https://github.com/igaw/stable-rt-tools
09:32:30 <pave1> Are those preempt-rt configs used in production? If so, what kind of application?
09:32:33 <iwamatsu> I heard that Daniel.W tested on test lab
09:32:38 <sangorrin> his test tool: https://github.com/igaw/jitterdebugger
09:33:13 <iwamatsu> We can use this, maybe
09:33:22 <sangorrin> he also contributed to rt-tests recently
09:33:58 <sangorrin> https://www.spinics.net/lists/linux-rt-users/
09:34:52 <iwamatsu> https://ci-rt.linutronix.de/RT-Test/
09:35:16 <sangorrin> if you can go to Linux Plumbers 2019 (portugal) they may hold an rt mini-conference
09:36:06 <pave1> sangorrin: I don't think I will be there.
09:36:25 <sangorrin> iwamatsu: nice link, here is the code https://github.com/ci-rt/docs
09:36:32 <pave1> sangorrin: Are you actually using RT stuff in production?
09:37:05 <sangorrin> yes, in many boards for many different systems
09:37:24 <pave1> sangorrin: What kind of applications is that?
09:37:41 <sangorrin> control
09:37:47 <gavinlai> pave1: something like this https://en.wikipedia.org/wiki/PROFINET
09:38:23 <gavinlai> I think we can discuss this after meeting :)
09:38:24 <pave1> Ok, thanks.
09:38:37 <pave1> gavinlai: agreed.
09:38:48 <gavinlai> #endmeeting