09:00:03 <szlin> #startmeeting CIP IRC weekly meeting
09:00:03 <brlogger> Meeting started Thu Jun  6 09:00:03 2019 UTC and is due to finish in 60 minutes.  The chair is szlin. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:03 <brlogger> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:03 <brlogger> The meeting name has been set to 'cip_irc_weekly_meeting'
09:00:08 <szlin> #topic rollcall
09:00:15 <szlin> please say hi if you're here
09:00:18 <pave1> hi!
09:00:19 <vidda> hi
09:00:23 <Yamamodo> hi
09:00:24 <iwamatsu> hi!
09:00:29 <patersonc> hi
09:00:47 <szlin> #topic AI review
09:00:49 <fujita[m]> hi
09:00:52 <szlin> 1. send investigating email for kernel-testing lab to cip-dev - patersonc
09:01:19 <patersonc> Still not done. Sorry
09:01:31 <szlin> patersonc: got it, I will keep this AI.
09:01:37 <szlin> #topic Kernel maintenance updates
09:02:29 <bwh> hi
09:02:32 <sangorrin> hi
09:02:32 <szlin> iwamatsu: pave1 Do you have any update on the topic of kernel maintenance updates
09:03:07 <pave1> szlin: I reviewed v4.19.48 and am finishing v4.19.47 (that was over 200 patches).
09:03:24 <szlin> pave1: wow, thank you!
09:03:50 <iwamatsu> szlin; I  reviewd 4.4.158 and 159, and I send some patches for 4.4.y to stable@kernel.org
09:04:13 <szlin> iwamatsu: thank you!
09:04:41 <szlin> so we can have new release in next Tuesday
09:05:10 <szlin> bwh: Do you have any update on this topic?
09:05:21 <bwh> no
09:05:37 <szlin> bwh: thanks.
09:05:42 <szlin> any other topic?
09:05:45 <pave1> Actually yes.
09:06:02 <pave1> I'm wondering if we could skip reviewing some of the stable patches.
09:06:22 <pave1> For example, there are staging drivers and s390 architecture in the stable.
09:06:34 <bwh> Of course you should skip those
09:06:45 <pave1> So my proposal would be to create a list of "we are not reviewing this"
09:07:04 <pave1> and then just mark it as "not reviewed -- out of scope" in the review list.
09:07:26 <szlin> pave1: it's the topic of CIP kernel maintenance scope
09:07:31 <pave1> I guess I could come up with list of paths we ignore and present it on the list.
09:08:01 <iwamatsu> pava1: That is a good idea.
09:08:06 <szlin> pave1: awesome
09:08:26 <szlin> bwh: do you have any comments on this?
09:09:24 <bwh> Ideally we can use the collected configs to create a list of source files that members actually use
09:09:59 <pave1> bwh: That might be even better, but I don't know how to do that.
09:10:00 <bwh> However we don't have that for 4.19 yet
09:10:14 <pave1> bwh: Plus it may limit future configurations.
09:11:30 <sangorrin> do we need a script here?
09:12:16 <bwh> I did find that someone did this before. I think it was using the "checker" hook in Kbuild to log each source file used.
09:13:22 <pave1> If someone has a pointers to existing scripts, that would be very useful.
09:13:37 <bwh> So, I can have try to find that again, or reimplement it along those lines
09:14:51 <szlin> #info https://elinux.org/images/3/39/Managing-Linux-Kernel-Configurations-with-Config-Fragments-Darren-Hart-VMware.pdf
09:16:30 <szlin> bwh: so you will provide the script for CIP kernel config collection
09:16:33 <bwh> OK
09:16:45 <szlin> bwh: thanks :D
09:16:54 <iwamatsu> bwh: thanks.
09:16:57 <szlin> #action Provide the script for CIP kernel config collection - bwh
09:17:03 <szlin> any other topic?
09:17:19 <fujita[m]> Does anyone kno
09:17:26 <fujita[m]> sorry
09:17:39 <szlin> fujita[m]: please go ahead
09:17:54 <fujita[m]> Is there any plan about next cip-rt kernel release?
09:18:49 <szlin> fujita[m]: ugh, we're discussing this topic today
09:19:49 <szlin> #action Provide the plan about next cip-rt kernel release - szlin
09:20:03 <fujita[m]> szlin: thank you
09:20:09 <szlin> fujita[m]: any time
09:20:15 <szlin> any other topic?
09:20:17 <sangorrin> One more thing, the configs for 4.19 probably need to be reviewed before we can say that everything in them needs to be supported. For example, some of them use CONFIG_NFS_FS which I think is hard to maintain.
09:21:01 <bwh> Yes. I am waiting to review those until all members have sent them
09:21:30 <sangorrin> bwh: OK, thanks.
09:21:39 <szlin> 3
09:21:41 <szlin> 2
09:21:42 <szlin> 1
09:21:55 <szlin> #topic Kernel testing
09:22:05 <szlin> patersonc: give the floor to you :)
09:22:24 <patersonc> Thanks
09:22:29 <patersonc> I've had meetings with Mentor about setting up a new LAVA lab for CIP.
09:22:33 <patersonc> They are currently waiting to exchange keys with the LF for the LAVA master.
09:22:39 <patersonc> They plan to add the SIMATIC IPC227E and Cyclone V DE0-Nano-SoC platforms.
09:22:56 <patersonc> We've also met and decided that CIP should use the gitlab-cloud-ci tool.
09:22:59 <patersonc> Michael is going to submit a formal proposal to the TSC.
09:23:06 <patersonc> Daniel is working on adding CI support for CIP Core (Deby).
09:23:09 <patersonc> Michael has already added the same for ISAR.
09:23:20 <patersonc> I need to sort out the Kernel builds...
09:23:33 <patersonc> That's it from me, unless there are any questions?
09:24:15 <szlin> any comments?
09:24:45 <szlin> 3
09:24:46 <szlin> 2
09:24:46 <szlin> 1
09:24:53 <szlin> #topic CIP Core
09:25:01 <szlin> The below information were provided by Kazu
09:25:01 <szlin> * Create patches so that isar-cip-core supports RZ/G1M iwg20m boards (on going)
09:25:01 <szlin> * Create the "Debian 10 buster" based demonstration layers in deby, that supports QEMU x86 64bit and BeagleBone Black
09:25:04 <szlin> * Held the first CIP-Core WG meeting and share the basic maintenance policies. Also planning to hold the second meeting to make a decision (or define action items) about the decision process of CIP maintained package list.
09:25:22 <szlin> any comments?
09:25:41 <szlin> 3
09:25:42 <szlin> 2
09:25:42 <szlin> 1
09:25:45 <szlin> #topic Software update
09:26:03 <szlin> sangorrin: give you the floor
09:26:11 <sangorrin> I am working on BBB watchdogs support now
09:26:35 <sangorrin> recentely a new command wdt was introduced, i want to add support for that on BBB as well
09:26:52 <sangorrin> Christian is also working on the integration of swupdate in ISAR, it will take a week or two
09:26:55 <sangorrin> thanks
09:27:04 <szlin> sangorrin: thanks
09:27:07 <szlin> any comments?
09:27:28 <szlin> #topic AOB
09:27:40 <sangorrin> for those who are coming to OSSJ
09:27:57 <sangorrin> if you come one day before (monday) we may have a meeting
09:28:12 <sangorrin> 1 day before the CIP meeting
09:28:14 <szlin> sangorrin: do you mean swupdate meeting
09:28:25 <sangorrin> cip core, swupdate, testing, kernel..
09:28:51 <patersonc> I wonder if we could meet during the conference at all?
09:29:10 <szlin> sangorrin: ah, you mean f2f meeting
09:29:10 <sangorrin> during the conference, sure
09:29:13 <patersonc> I think I'm likely to have internal meetings on Monday
09:29:18 <patersonc> Or do we meet when the board meeting meets?
09:29:43 <sangorrin> Jan will come 1 day before
09:29:58 <sangorrin> so we are going to have a meeting
09:30:05 <sangorrin> but of course we will have more meetings
09:30:08 <patersonc> Okay
09:30:38 <sangorrin> thanks
09:31:29 <szlin> I would like to introduce my colleague
09:31:43 <szlin> Yamamodo: <- please welcome him
09:31:45 <szlin> :D
09:31:48 <Yamamodo> hi, i am sz's partner, Moxa
09:31:58 <Yamamodo> nice to meet you
09:32:08 <pave1> Hi, Yamamodo; nice to meet you!
09:32:11 <patersonc> Yamamodo: Hello!
09:32:18 <sangorrin> hi Yamamodo, nice name
09:32:37 <sangorrin> in Japanese: "mountain mode!"
09:32:42 <Yamamodo> haha 3Q :)
09:32:59 <szlin> any other business?
09:33:00 <iwamatsu> Yamamodo: Hi!
09:33:05 <szlin> 3
09:33:06 <szlin> 2
09:33:07 <szlin> 1
09:33:10 <szlin> #endmeeting