09:00:13 <szlin> #startmeeting CIP IRC weekly meeting
09:00:13 <brlogger> Meeting started Thu May  9 09:00:13 2019 UTC and is due to finish in 60 minutes.  The chair is szlin. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:13 <brlogger> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:13 <brlogger> The meeting name has been set to 'cip_irc_weekly_meeting'
09:00:17 <szlin> #topic rollcall
09:00:23 <szlin> please say hi if you're here
09:00:26 <gavinlai> hi
09:00:29 <kazu_> hi
09:00:34 <vidda> hi
09:00:51 <patersonc> hi
09:01:19 <szlin> #topic Kernel maintenance updates
09:01:23 <pave1> hi
09:01:30 <szlin> pave1: do you have any update?
09:01:31 <fujita[m]> hi
09:01:40 <szlin> iwamatsu: are you around?
09:01:45 <pave1> sziln: Update on what?
09:01:59 <szlin> about kernel maintenance
09:02:00 <bwh> hi
09:02:08 <pave1> Actually, yes.
09:02:23 <szlin> we're in topic of kernel maintenance
09:02:37 <pave1> I tried reviewing -stable kernel in the rc stage...
09:02:43 <pave1> And it seemed to make a lot of sense:
09:02:52 <iwamatsu> Hi
09:03:15 <pave1> That way people actually react to the review, and it is still early enough to prevent "bad" patch from going to -stable.
09:03:56 <pave1> It does not add much work because we'd review the patch a bit later...
09:04:13 <pave1> So I wanted to ask if it is okay to do that?
09:04:20 <patersonc> Seems sensible to me
09:04:32 <bwh> Of course, it is just a tight timetable
09:04:37 <szlin> LGTM, any objection?
09:05:23 <pave1> bwh: Yes, it is a bit tight. I don't think we can make it every time, but if we miss the deadline, we are no worse than today :-)
09:05:50 <szlin> #agreed Start to review stable kernel in rc stage
09:06:00 <szlin> iwamatsu: do you have any comment?
09:06:50 <iwamatsu> I am reviewing stable-rc tree and released tree too, and some partches are applied into 4.19.y.
09:07:13 <szlin> iwamatsu: thanks!
09:07:51 <szlin> bwh: do you have any update on this topic?
09:08:02 <bwh> I don't
09:08:30 <szlin> any other comment?
09:08:57 <szlin> 3
09:08:58 <szlin> 2
09:08:59 <szlin> 1
09:09:08 <szlin> #topic Kernel testing
09:09:10 <iwamatsu> Should we send the results of the review to cip-dev as well?
09:09:11 <patersonc> I have a question for iwamatsu regarding Kernel configs
09:09:56 <iwamatsu> patersonc: please
09:10:13 <patersonc> Where did the v4.19 version of renesas_shmobile_defconfig come from in https://gitlab.com/cip-project/cip-kernel/cip-kernel-config/blob/master/4.19/arm/renesas_shmobile_defconfig?
09:12:57 <iwamatsu> maybe, it was used 4.9.13.
09:13:16 <iwamatsu> If my memory is correct...
09:13:28 <patersonc> Okay. I'll update it to what is in v4.19
09:13:30 <szlin> iwamatsu: that will be great, we can discuss the working model in my previous email
09:14:12 <iwamatsu> szlin: OK.
09:14:45 <szlin> patersonc: give the floor to you
09:14:50 <patersonc> Thanks
09:15:29 <patersonc> As it looks like CIP will join KernelCI, I propose we don't create our own instance of KernelCI.org, instead we submit any test results to the central website.
09:15:50 <sangorrin> Agree
09:15:50 <patersonc> The only reason not to do this is if there are CIP specific test results we don't want to share to kernelci.org
09:15:51 <patersonc> Any thoughts?
09:16:28 <sangorrin> They will be available on LAVA which is also public
09:16:45 <patersonc> True
09:17:02 <patersonc> I'm not sure https://kernelci.ciplatform.org/ will add much for us
09:17:49 <patersonc> info: I've asked the LF admin to stop working on CIP's KernelCI instance whilst we wait for the outcome of whether CIP will join the KernelCI project or not.
09:18:17 <sangorrin> We could use ours for practicing before sending the results to the official one... but it depends on the costs
09:18:54 <patersonc> At the moment we haven't got the LAVA->KernelCI link working anyway
09:20:05 <szlin> any comment?
09:20:06 <sangorrin> Then let's wait until it is decided finally as you say
09:20:27 <patersonc> Other update: We hope to have an RZ/G2E board in the CIP lab this week.
09:21:18 <szlin> patersonc: thanks!
09:21:40 <szlin> any comment?
09:21:59 <szlin> 3
09:22:00 <szlin> 2
09:22:01 <szlin> 1
09:22:02 <pave1> I tried to play with LAVA. Sorry if I spammed some kind of mailing
09:22:02 <pave1> list with results.
09:22:17 <patersonc> Not at all. I'm glad you managed to run some tests :D
09:22:28 <patersonc> Let us know if there is anything we can do to help
09:22:53 <szlin> #topic CIP Core
09:22:55 <pave1> Is there some "more interactive" way to run commands?
09:23:51 <szlin> pave1: sorry that could we can discuss this matter after the meeting?
09:23:55 <patersonc> pave1: You can use lavacli to programatically submit test jobs
09:24:09 <pave1> Yep, sorry. Lets talk after meeting.
09:24:15 <szlin> pave1: thank you
09:24:21 <sangorrin> there are ssh sessions
09:25:17 <sangorrin> https://validation.linaro.org/static/docs/v2/hacking-session.html
09:25:32 <szlin> CIP security working group will come out the essential packages list and all dependencies
09:25:44 <szlin> kazu_: do you have any update on CIP core?
09:25:57 <kazu_> I've summarized the comments about the package list in cip-dev
09:26:07 <kazu_> Also created the list of binary packages (and corresponding source packages) installed by deboostrap minbase
09:26:15 <kazu_> I'll send this information to cip-dev later
09:26:36 <kazu_> I would like to confirm how I consider the remaining packages suggested by security WG: acl, pam, shadow / auditd / openssh / tpm2-tools
09:26:52 <kazu_> Maybe should I wait the report from security WG?
09:27:03 <szlin> #action Send list of binary packages to cip-dev - kazu
09:27:07 <szlin> kazu_: yes, please.
09:27:14 <kazu_> szlin: thanks!
09:27:24 <szlin> kazu_: thank you.
09:27:31 <szlin> any other comment?
09:27:42 <szlin> 3
09:27:44 <szlin> 2
09:27:45 <szlin> 1
09:28:05 <szlin> #topic Software update
09:28:49 <sangorrin_> back here
09:29:04 <sangorrin_> software updates?
09:29:10 <szlin> the Debian package of swupdate is still in NEW queue
09:29:11 <kazu_> yes
09:29:12 <szlin> yes
09:29:17 <sangorrin_> we just had a 1h online conference with Christian
09:29:40 <sangorrin_> Suzuki-san was able to create a Lua handler for A/B sw updates using swupdate and rdiff
09:30:11 <sangorrin_> Next step: Christian will be sharing some code and we will integrate it on ISAR
09:30:48 <szlin> sangorrin_: thanks
09:30:54 <szlin> any other comment?
09:31:01 <sangorrin_> Apart from that we had discussions with Linaro, but so far nothing has been decided
09:32:05 <szlin> 3
09:32:12 <szlin> 2
09:32:13 <szlin> 1
09:32:19 <szlin> #topic AOB
09:32:25 <szlin> any other business?
09:32:51 <szlin> 3
09:32:54 <szlin> 2
09:32:55 <szlin> 1
09:33:00 <szlin> #endmeeting