09:00:09 <szlin> #startmeeting CIP IRC weekly meeting
09:00:09 <brlogger> Meeting started Thu Mar 14 09:00:09 2019 UTC and is due to finish in 60 minutes.  The chair is szlin. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:09 <brlogger> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:09 <brlogger> The meeting name has been set to 'cip_irc_weekly_meeting'
09:00:15 <szlin> #topic rollcall
09:00:21 <szlin> please say hi if you're here
09:00:26 <vidda> hi
09:00:27 <gavinlai> hi
09:00:38 <mungaip[m]> hi
09:00:42 <fujita[m]> hi
09:00:43 <bwh> hi
09:01:06 <szlin> #topic AI review
09:01:06 <patersonc> hi
09:01:11 <szlin> Action items:
09:01:12 <szlin> 1. Iwamatsu-san will create a template page and send the link via mailing list afterward
09:01:14 <szlin> -> Done
09:01:17 <szlin> #info https://lists.cip-project.org/pipermail/cip-dev/2019-March/001814.html
09:01:34 <szlin> Please review and provide your opinion on this proposal
09:02:02 <szlin> via cip-dev mailing list
09:02:09 <szlin> 2. Please send configuration file of kernel 4.19 to cip-dev before end of March.
09:02:16 <szlin> #topic Kernel maintenance updates
09:02:23 <szlin> Iwamatsu-san is working on releasing a new CIP kernel
09:02:36 <szlin> bwh: Do you have any update on this topic?
09:02:51 <bwh> I don't
09:03:18 <szlin> bwh: thanks
09:03:28 <szlin> wagi: are you around?
09:03:41 <patersonc> o/
09:03:54 <szlin> patersonc: please go ahead
09:04:09 <patersonc> Regarding configs for v4.19, what do we want to do about arm64? Upstream there is just one giant defconfig and this is what we tend to use with RZ/G2 platforms. We don't really have a product driven config. I assume the CIP maintainers don't really want to maintain everything?
09:04:51 <szlin> bwh: do you have any comments?
09:05:33 <bwh> I was planning to send something about security hardenin options...
09:06:52 <szlin> patersonc: wagi had shared this slide - https://events.linuxfoundation.org/wp-content/uploads/2017/12/oss-eu-2018-kernel-config-dvhart-v2_Darren-Hart.pdf
09:07:37 <patersonc> Thanks szlin
09:08:01 <szlin> patersonc: perhaps we can refer to this mechanism
09:08:48 <szlin> bwh: do you have any comments on configuration management?
09:08:59 <patersonc> We'd still need a reduced base though, rather than arm64 defconfig
09:09:23 <patersonc> Unless we do want to maintain it all, but it's huge
09:10:17 <bwh> szlin: We should probably review the options as I did for 4.4
09:10:22 <szlin> patersonc: agree
09:10:49 <szlin> bwh: noted, thanks
09:10:49 <bwh> I don't have anything more specific to say for now
09:11:23 <szlin> any other comments?
09:11:28 <szlin> 3
09:11:30 <szlin> 2
09:11:31 <szlin> 1
09:11:42 <szlin> #topic Kernel testing
09:11:58 <patersonc> We have now made it possible for targets in the Renesas LAVA lab to have access to the internet. This should make it easier to run the Linaro test-definitions, including things like LTP.
09:12:01 <patersonc> Hopefully we'll get the relevant patches out this week.
09:12:27 <patersonc> Little progress on getting the CIP KernelCI instance linked to the LAVA master though. We're having some problems with the tokens.
09:12:35 <patersonc> There is light at the end of the tunnel though.
09:13:44 <patersonc> o
09:13:47 <patersonc> That's me done
09:13:54 <szlin> patersonc: would you like to share the issues afterward?
09:14:26 <patersonc> Sure
09:14:27 <szlin> patersonc: because other members might face the same issues in the near future
09:14:36 <szlin> patersonc: thanks!
09:14:43 <patersonc> We'll publish a guide once we have it working etc.
09:14:43 <szlin> any other comments?
09:15:05 <szlin> patersonc: that's awesome
09:15:06 <szlin> 3
09:15:07 <szlin> 2
09:15:07 <szlin> 1
09:15:13 <szlin> #topic CIP Core
09:15:13 <szlin> Daniel has added usbutils to CIP Core (Deby) for Patryk to use lsusb in Patryk's tests
09:15:17 <szlin> Suzuki-san has found a couple of issues in ISAR CIP Core.
09:15:24 <szlin> #info https://lists.cip-project.org/pipermail/cip-dev/2019-March/001817.html
09:15:31 <szlin> any other comments?
09:15:45 <szlin> 3
09:15:48 <szlin> 2
09:15:51 <szlin> 1
09:15:54 <fujita[m]> o/
09:16:16 <szlin> fujita[m]: please go ahead
09:16:21 <fujita[m]> Iwamatsu-san sent an email to ML about the version of debian used as CIP core
09:16:50 <fujita[m]> I'm worried about that
09:17:14 <szlin> #info https://lists.cip-project.org/pipermail/cip-dev/2019-March/001816.html
09:17:57 <szlin> fujita[m]: Daniel repled that he will switch to Debian 10
09:18:15 <szlin> s/repled/replied
09:18:44 <fujita[m]> CIP testing and some are using jessie now
09:20:05 <fujita[m]> Please note that > all
09:20:30 <szlin> fujita[m]: thanks.
09:20:59 <szlin> fujita[m]: do you have timetable for upgrading in CIP testing?
09:21:41 <fujita[m]> I don't have, sorry
09:21:42 <szlin> fujita[m]: I suggest  we can discuss this item in cip-dev
09:21:47 <szlin> #topic Software update
09:21:59 <szlin> [Quote from Daniel] Regarding SWUpdate we hit an issue that we had not expected before. Suzuki-san was trying to update the standard BBB debian image (or a yocto-made one), but there were many warnings about orphan nodes etc. After some investigation the reason seems to be that the rootfs is modified during the first boot (or something like that). This is probably one of the biggest problems with updating
09:22:04 <szlin> images instead of files.
09:22:25 <szlin> I have little time in swupdate packaging task this week
09:22:55 <szlin> I hope swupdate could be uploaded in next week.
09:23:00 <szlin> #action Daniel has to upload to the wiki the SW updates tool comparison document
09:23:02 <szlin> #action Mae please add a link to the SW updates wiki page from the embedded world CIP release page
09:23:07 <szlin> #info https://lists.cip-project.org/pipermail/cip-dev/2019-March/001817.html
09:23:13 <szlin> any other comments?
09:23:14 <szlin> 3
09:23:15 <szlin> 2
09:23:16 <szlin> 1
09:23:30 <szlin> #topic AOB
09:23:36 <szlin> any other business?
09:23:52 <szlin> 3
09:23:52 <szlin> 2
09:23:52 <szlin> 1
09:24:05 <szlin> #endmeeting