09:00:05 <szlin> #startmeeting CIP IRC weekly meeting
09:00:05 <brlogger> Meeting started Thu Mar  7 09:00:05 2019 UTC and is due to finish in 60 minutes.  The chair is szlin. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:05 <brlogger> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:05 <brlogger> The meeting name has been set to 'cip_irc_weekly_meeting'
09:00:15 <szlin> #topic rollcall
09:00:20 <szlin> please say hi if you're here
09:00:29 <mungaip[m]> hi
09:00:43 <fujita[m]> hi
09:01:13 <szlin> #topic AI review
09:01:20 <szlin> Action items:
09:01:21 <szlin> 1. Iwamatsu-san will introduce kernel patch review mechanism in 3/7 IRC meeting
09:01:28 <szlin> iwamatsu: are you around?
09:01:48 <iwamatsu> hi
09:02:43 <iwamatsu> Yes, I thought a little.
09:02:44 <sangorrin> hi!
09:03:03 <szlin> iwamatsu: could you describe  your idea with kernel patch review mechanism?
09:03:10 <szlin> sangorrin: (wave ._./
09:04:46 <iwamatsu> 1. A new LTS will be released.
09:04:47 <iwamatsu> 2. Create a list on wiki.
09:04:47 <iwamatsu> 3. Mark the review and the name of the worker and mark (UR: under review) under the commit.
09:04:47 <iwamatsu> 4. When the review is over, update the mark.
09:04:47 <iwamatsu> 5. Work report on IRC.
09:05:31 <iwamatsu> It's classic though.
09:05:44 <szlin> any comments?
09:05:57 <szlin> vidda: ^
09:06:57 <szlin> sangorrin: any comments?
09:07:33 <iwamatsu> Also, if the method using the wiki is troublesome, I think that we can move to git (gitlab).
09:07:58 <szlin> iwamatsu: I have some questions, how to create a wiki page when new LTS released?
09:08:14 <szlin> by hand or script
09:08:27 <iwamatsu> using script
09:08:48 <iwamatsu> I already creating script for that.
09:08:53 <szlin> iwamatsu: wow, thanks.
09:09:09 <sangorrin> ops
09:09:15 <iwamatsu> And if it is necessary to reflect on the wiki, I will periodically update it.
09:09:20 <szlin> iwamatsu: I think we can have a trial run
09:09:43 <iwamatsu> szlin: Okay.
09:10:13 <szlin> iwamatsu: could you create a template page and send the link via mailing list afterward?
09:10:34 <sangorrin> for me it's a bit hard right now to review the patches
09:10:36 <iwamatsu> szlin: ok, will do.
09:10:59 <sangorrin> but it will be nice to have that list on the website for the testing
09:11:06 <sangorrin> website=wiki
09:11:25 <szlin> sangorrin: I understand, thanks for the feedback
09:11:48 <szlin> #action Iwamatsu-san will create a template page and send the link via mailing list afterward
09:12:07 <szlin> iwamatsu: do you have schedule on it?
09:12:17 <szlin> how about before next IRC meeting?
09:12:45 <szlin> any comments?
09:12:50 <szlin> 3
09:12:51 <szlin> 2
09:12:51 <szlin> 1
09:12:59 <szlin> #topic Kernel maintenance updates
09:13:01 <szlin> #action Please send configuration file of kernel 4.19 to cip-dev before end of March.
09:13:16 <szlin> iwamatsu: do you have any updates?
09:13:25 <szlin> wagi: are you around?
09:13:56 <iwamatsu> szlin: no, I am working update linux kernel 4,4 and 4.19.
09:14:11 <szlin> iwamatsu: noted with thanks.
09:14:16 <szlin> any comments?
09:14:17 <szlin> 3
09:14:18 <szlin> 2
09:14:19 <szlin> 1
09:14:22 <szlin> #topic Kernel testing
09:14:38 <mungaip[m]> patersonc is not around so I'll update
09:14:48 <mungaip[m]> We have now added some RZ/G1 test cases to the cip-kernel tests repo
09:14:55 <mungaip[m]> https://gitlab.com/cip-project/cip-testing/cip-kernel-tests
09:15:01 <mungaip[m]> All the integration tests work with cip-core other than USB (I thing lsusb is missing in the rfs?)
09:15:12 <mungaip[m]> We're working on getting kernelci working
09:15:19 <mungaip[m]> and continuing to look into Linaro's LAVA test repo to see how we can use their tests
09:15:28 <mungaip[m]> Our boards have no access to the internet so cannot download dependencies or test files
09:16:26 <szlin> ^ because of firewall?
09:17:14 <mungaip[m]> No, the router cannot see our boards
09:17:42 <szlin> mungaip[m]: thanks for the update
09:17:45 <szlin> any comments?
09:17:45 <szlin> 3
09:17:46 <szlin> 2
09:17:47 <szlin> 1
09:18:06 <szlin> #topic CIP Core
09:18:13 <sangorrin> back here
09:18:26 <sangorrin> cip core..
09:18:49 <szlin> sangorrin: yes
09:18:52 <sangorrin> I think that there is a need to clarify the differences between ISAR and meta-eid
09:18:58 <wagi> szlin: around but also in a telco
09:19:07 <sangorrin> and what are each member's use case maybe
09:19:48 <sangorrin> also we need to decide the procedure to apply for new packages
09:20:07 <sangorrin> i don't have much time now but if you have any suggestion i would appreciate
09:20:25 <sangorrin> maybe just an email and 1 vote from each member!?
09:21:46 <szlin> sangorrin: how to decide? e.g., > 50%
09:23:15 <szlin> any comments?
09:24:00 <fujita[m]> What should we decide first?
09:24:29 <fujita[m]> Use case may be most important
09:25:39 <szlin> sangorrin: are you around?
09:26:12 <szlin> sangorrin: oops
09:26:19 <sangorrin_> sorry i got kicked off or somethign
09:26:30 <szlin> sangorrin: did you see the question from fujita?
09:26:40 <sangorrin_> nope
09:26:45 <sangorrin_> could you copy&paste?
09:26:48 <szlin> 17:21 < szlin> sangorrin: how to decide? e.g., > 50%
09:26:49 <szlin> 17:23 < szlin> any comments?
09:26:49 <szlin> 17:23 < fujita[m]> What should we decide first?
09:26:49 <szlin> 17:24 < fujita[m]> Use case may be most important
09:27:23 <sangorrin_> yes
09:27:32 <sangorrin_> we can decide a small obvious set first
09:27:40 <sangorrin_> and then have each member add their own
09:27:55 <sangorrin_> how to decide: more than 50% is fine i guess
09:28:22 <sangorrin_> well we are going to decide what packages need to be maintained
09:28:44 <sangorrin_> we can't maintain all packages properly i think, we need to go from the most important ones
09:29:01 <szlin> I suggest to mention mechanism of vote in TSC meeting
09:29:09 <sangorrin_> got it
09:29:44 <szlin> sangorrin_: do you have time table with small set?
09:30:13 <sangorrin_> i will prepare something
09:30:46 <sangorrin_> i have extracted the packages used in cip-core Deby, but not isar yet
09:31:11 <szlin> sangorrin_: will you list the small set with source package or binary package?
09:31:40 <sangorrin_> well, this is something i want to explain because some members didnt understand
09:31:45 <sangorrin_> we need two lists
09:31:58 <sangorrin_> one list is for maintenance, and we need source package names
09:32:22 <sangorrin_> the other list is for the build tools, and we need binary package names
09:32:57 <sangorrin_> so the second list is a "requirement" for build tools
09:33:10 <sangorrin_> the first list is a requirement for source code maintainers
09:33:52 <szlin> #info sangorrin will prepare two lists for cip-core. First list is a requirement for source code maintainers and second list is a "requirement" for build tools
09:34:19 <szlin> any comments?
09:34:41 <szlin> 3
09:34:42 <szlin> 2
09:34:43 <szlin> 1
09:34:44 <szlin> #topic Software update
09:34:58 <iwamatsu> sangorrin_: For example, in the case of deby, they can be obtained from core-image-minimal defined by deby.
09:35:41 <sangorrin_> iwamatsu: yes, I already have that list. My goal is to know how many recipes we need to create because creating recipes takes time
09:36:05 <szlin> I'm working on Debian packaging with swupdate.
09:36:17 <sangorrin_> szlin: thanks a lot
09:36:28 <szlin> any comments?
09:36:35 <sangorrin_> suzuki-san is now checking that Christian fix is working
09:36:44 <sangorrin_> we are using a beagle bone black now
09:36:48 <iwamatsu> sangorrin_: I see.
09:36:55 <szlin> sangorrin_: thanks for the update.
09:37:04 <szlin> 3
09:37:07 <szlin> 2
09:37:12 <szlin> 1
09:37:17 <szlin> #topic AOB
09:37:20 <szlin> any other business?
09:37:36 <szlin> 3
09:37:37 <szlin> 2
09:37:38 <szlin> 1
09:37:42 <szlin> #endmeeting