09:00:01 <gavinlai> #startmeeting CIP dev weekly meeting
09:00:01 <brlogger> Meeting started Thu Jan 31 09:00:01 2019 UTC and is due to finish in 60 minutes.  The chair is gavinlai. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:01 <brlogger> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:01 <brlogger> The meeting name has been set to 'cip_dev_weekly_meeting'
09:00:15 <gavinlai> #roll call
09:00:23 <gavinlai> please say hi if you're here
09:00:26 <patersonc> hi
09:00:29 <vidda> hi
09:00:37 <mungaip[m]> hi
09:00:44 <sangorrin> hi
09:00:47 <iwamatsu_> hi
09:01:38 <gavinlai> #topic Kernel maintenance updates
09:01:58 <gavinlai> szlin is sending PR for CVE-2019-3701.yml to cip-kernel-sec
09:02:35 <gavinlai> iwamatsu_: any update for the new kernel?
09:03:34 <iwamatsu_> gavinlai: I will release v4.4.172 cip kernel today.
09:04:07 <gavinlai> #action iwamasu will release v4.4.172 cip kernel today
09:04:09 <gavinlai> thanks
09:04:26 <iwamatsu_> There are no other update.
09:04:39 <gavinlai> iwamatsu_: thanks
09:05:06 <gavinlai> #topic Kernel testing
09:05:33 <patersonc> This week:
09:05:40 <patersonc> Added a workaround for the iwg22m bootloader issues. Daily healthchecks should now always pass (unless there is an actual h/w issue)
09:05:47 <patersonc> Daily QEMU healthchecks are now using the v4.4.166-cip29 Kernel.
09:05:52 <patersonc> Lab health can be viewed here: https://lava.ciplatform.org/scheduler/labhealth/
09:06:22 <patersonc> We're also still working on making some test scripts public that will run on the iwg2* boards
09:06:45 <patersonc> Any queries?
09:07:06 <gavinlai> #info patersonc Added a workaround for the iwg22m bootloader issues
09:07:15 <gavinlai> #link https://lava.ciplatform.org/scheduler/labhealth/
09:07:24 <szlin> I'm back now, sorry for late.
09:07:55 <gavinlai> I think we can move to next topic?
09:08:14 <patersonc> Sure. Thanks
09:08:19 <gavinlai> patersonc: thanks for update:)
09:08:20 <gavinlai> #topic CIP Core
09:08:36 <sangorrin> I am now pushing built images to AWS regularly
09:08:48 <sangorrin> of the renesas board
09:09:03 <sangorrin> I have also changed the gitlab repository structure to accomodate for ISAR
09:09:17 <sangorrin> I am now changing links on the wiki
09:09:42 <sangorrin> next i want to create a small list of packages for cip core v2
09:10:20 <sangorrin> any question?
09:10:44 <gavinlai> may I add the action item ?
09:10:55 <sangorrin> sure
09:11:13 <gavinlai> #action sangorrin will create a small list of packages for cip core v2
09:11:14 <sangorrin> AI: list of packages for cip core v2 tiny profile
09:11:32 <gavinlai> #undo
09:11:32 <brlogger> Removing item from minutes: #action sangorrin will create a small list of packages for cip core v2
09:11:45 <gavinlai> #action sangorrin will list of packages for cip core v2 tiny profile
09:11:56 <gavinlai> sangorrin: thanks :)
09:12:07 <sangorrin> thanks
09:12:29 <gavinlai> #topic Software update
09:12:53 <sangorrin> I created a report of a survey i conducted among members (not public)
09:13:12 <sangorrin> from there and my own investigation i created a list of requirements (public, see cip-dev)
09:13:29 <sangorrin> and from those requirements i created an initial architecture (see cip-dev)
09:13:54 <sangorrin> next, compare tools for implementing that architecture, and create a PoC
09:14:07 <sangorrin> but basically i want to use casync
09:14:13 <sangorrin> any question?
09:15:00 <sangorrin> please send me feedback on the mailing list
09:15:07 <gavinlai> #info sangorrin sent an architecture draft to cip-dev
09:15:14 <gavinlai> #link https://lists.cip-project.org/pipermail/cip-dev/2019-January/001767.html
09:15:15 <szlin> sangorrin: which reason do you think casync is better
09:15:28 <sangorrin> I will answer that on the mailing list
09:15:43 <szlin> sangorrin: thanks.
09:16:06 <gavinlai> sangorrin: thanks
09:16:11 <sangorrin> thanks
09:16:12 <gavinlai> any other point?
09:16:52 <gavinlai> #topic AOB
09:17:54 <szlin> yes
09:18:13 <szlin> iwamatsu_: could you please update the wiki with kernel 4.19?
09:18:16 <szlin> iwamatsu_: https://wiki.linuxfoundation.org/civilinfrastructureplatform/cipkernelmaintenance
09:18:37 <iwamatsu_> szlin: OK
09:18:43 <szlin> iwamatsu_: thank you!
09:19:39 <sangorrin> maybe the start page as well
09:19:40 <sangorrin> https://wiki.linuxfoundation.org/civilinfrastructureplatform/start
09:20:25 <sangorrin> the links are pointing to the old repositories i think
09:21:36 <gavinlai> any other update?
09:22:06 <gavinlai> #endmeeting